Recent articles (showing 11-20 out of 69):
WARNING: This post has been marked as obsolete and may be incorrect. It is kept for archival purposes only.
The default console in FreeBSD is 80 x 25 geometry in whatever default resolution it can choose... but sometimes you want more.
So here's how to set a new resolution...
First, you need to load the VESA driver into the kernel (if it's not already loaded) – ignore any errors...
kldload vesa Copy
Next, you need to query the console to find out what modes are available, to do this type (as root):
vidcontrol -i mode < /dev/console Copy
This will output all the available modes for your card+monitor. An example of one of the lines on my card is as follows:
280 (0x118) 0x0000001f G 1024x768x32 D 8×16 0xa0000 64k 64k 0xf3000000 3072k Copy
(mode 280 is 1024 x 768 in 32-bit colour and uses a 8×16 font)
This is the mode I want to use, and I want to increase my geometry from 80×25 to 132×60, so I can type the following command to one-time set it:
vidcontrol -g 132×60 MODE_280 < /dev/console Copy
If you want to use this as the default every boot, add the following line to your /etc/rc.conf file:
allscreens_flags="-g 132×60 MODE_280" Copy
And also load the VESA driver on boot, by adding the following line to your /boot/loader.conf file:
vesa_load="YES" Copy
That's all there is to it.